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1. OBJECTIVE 
 
The objective of this manual is ultimately to make SEM images ready for FOAMS. The 
required input for FOAMS is a set of images with distinct shades of gray corresponding 
to various analyzable objects (i.e. bubbles, crystals). Shades of gray have values between 
0 and 255 (called Digital Numbers=DN). For instance, all bubbles might have a DN value 
of 0 and the other objects intermediate values between this and white (DN=255).  
For example chosen DNs for measured objects can be: 

- DN=0 (black) are bubbles 
- DN=100 (dark grey) are leucites 
- DN=200 (light grey are glass walls 
- DN=255 (white) are other crystals 

 
The absolute DN value is not important since the language FOAMS uses is “what level of 
grey do I analyze?”. All that matters is that they must be different from each other. 
 
These instructions were designed for Adobe Photoshop© and the applicability of this 
manual is not guaranteed for other software. 
 
 
2. STEP‐BY‐STEP INSTRUCTIONS 
 
 
A. Making the image ready 

 
The image is first opened in Photoshop. Most 
of the time, SEM images are in indexed mode. 
Less often they are saved as color or grayscale 
images. Since SEM only displays brightness 
differences we do not need to work with color. 
Therefore, the user must convert the image to 
grayscale: 
 
 [Image] → [Mode] → [Grayscale] 
 
To facilitate extraction of the various object 
types from the image, copies of the 
“background” layer are made. The user should 
have at least as many copies of the background 
as the number of different object types. These 
copies are made using: 
 
{Right‐Click on background layer}  
→ [duplicate] 
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Important note: All the tools used to draw or select objects have by default ‘anti‐
aliasing’ checked. This is a useful thing to make nice transitions between boundaries, 
and who do not wish to have too many edgy pixels. For example, when selecting a 
triangular area inside a blank image, and using the bucket or the fill function to paint it 
black, if anti‐aliasing is checked into the selection tool (lasso, rectangle, ellipse or 
polygonal), the edges will appear as though there is a gradient between black and white 
(see Figure below). This is the anti‐aliasing smoothing effect. We absolutely DO NOT 
want this for our images. In all your selection tools, magic wand and paint bucket, 
uncheck anti‐aliasing. 

 
The effects of anti‐aliasing being checked “on” (left triangle) and “off” (right triangle) 
 
 
B. Obtaining object layers automatically 
 
We will start by making a new layer for our Class 1 (bubbles). To do this, do either: 
 
[Layer] → [New] → [Layer] 
 
or do: 
 
 Shft+Ctrl+N 
 
Now rename your new layer (“bubble” for instance). Select one of your background 
images as your active layer (click on it on the layer window). The grayscale levels need 
to be adjusted so that bubbles stand out as well as possible.  
Go to: 
 
 [Image] → [Adjust] → [Levels]  
 
and displace your bars to whichever value gives you the best result.  
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In the image above, some bubbles are often not well imaged (see arrows). In this case, 
the left level marker in the histogram can be displaced to the right and the light level to 
the left. The middle one is positioned to obtain the best result.  
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Now these areas are completely black but still have little broken “glass” pieces inside 
them.  
 
After this is done, bubbles will be selected according to their level of gray. To do this, do: 
 
[Select] → [Color Range] 
 
 
 A small window appears that allows the user to 
sample a color on the image. The cursor is now 
an eyedropper. Click on the image into one of 
these objects (black bubbles). Set the threshold 
bar named ‘Fuzziness’ located in the small 
window to a satisfactory level. When set too low, 
some bubble pixels that are not completely black 
will not be accounted for. On the preview image 
the bubbles should now appear as white objects.  
 
 
 
To see what is actually selected, press [OK].  
 
Zoom in on different parts of your bubble borders to see if they have been well 
included. If you see that some are missing, undo your last step (Ctrl+Z to go back one 
step, Ctrl+Alt+Z to go back further steps) and redo with a different fuzziness. 
 
The other quicker way to do it, is to use the magic wand tool. The fuzziness is 
substituted by ‘tolerance’ which can be set to 20; To ensure that all objects are selected, 
uncheck the “contiguous” option in the toolbar (and the anti‐alias if not already done). 
Click on any black bubble and the rest should now be selected as well. 
 
Now activate your ‘bubble’ layer by clicking on it. The bubble selection should still be 
active. Fill your selection with black (DN=0) either using the paint bucket (unchecking 
contiguous in the tool options above) or by doing: 
 
 [Edit] → [Fill] 
 
Now your objects should be fully black. 
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Several issues can be typically noted at this stage if all layers BUT the bubble layer are 
unchecked. On the image, some thin black contours appear and they are obviously not 
bubbles but probably crystal contours. We can correct for these now, or later. If only a 
few of them are present, they should be erased manually for minimum error. If the 
image is full of such small unwanted areas, there is an easy way to get rid of them by 
making however a small sacrifice on the accuracy of object boundaries. Do: 
 
[Select]→[ Color Range] (or magic wand) 
 
Sample a bubble color. Then do: 
 
 [Select] → [Modify] → [Contract]  
 
and choose 1 pixel. This eliminates all the smallest noise objects (in theory!) however 
note that the selection zones concerning your other objects are also now reduced. Do  
 
[Select] → [Modify] → [Expand]  
 
and choose 1 pixel again.  
 
Finally, go to 
 
 [Select]→[Inverse] 
 
 and delete the areas that were outside your now corrected selection.  
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The higher the # of pixels used for the contraction/expansion phase, the less coherent 
your object shapes will be when re‐expanding.  
Once all of this is done the image should not contain non‐bubble areas:  
 

 
 
 
More often than not, glass wall fragments that are not part of a bubble or other 
heterogeneities can be present within bubble areas. They should be removed by 
coloring the area in black using the pencil tool (choose an adequate pencil thickness). To 
identify easily such regions of the image, activate your background and look for portions 
that need reworking. 
 
 
 
 
 
C. Making subsequent object layers 

 
This step is necessary when the sample contains more than two phases (e.g. more than 
glass and bubbles). Often samples contain phenocrysts whose areas have to be 
discarded from the analysis of bubbles in order to reference them to melt only. If this is 
the case, make a new layer. Select it, rename it (“crystals” here). Activate your 
“background crystals”. If there is a significant number of large crystals, do [levels] and 
the rest of the automatic selection procedure described above. If only few are present 
they can be easily contoured and filled using selection tools. 
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D. Manually selecting the rest of the objects 
 
These are the objects that cannot be distinguished from one another only by brightness 
differences (for example a leucite or plagioclase crystal and volcanic glass) and the 
image contains a substantial number of them. These need to be contoured and filled. 
Any way is good to do this. We generally follow this procedure: 
 
Make a new layer. Activate. Use the polygonal or another lasso selection tool and fill. As 
it can be bothersome to always have to use the mouse to get to the different menus I 
strongly advise the use of macros. For example, I use the F2 key to fill objects instead of 
going to the menus.  
 
To make a “fill” macro: 
 
‐ Select any kind of object on any image in Photoshop 
 
‐ Choose any color in the color selection window 
 
‐ Go into your Actions window and click on the little icon that says [New Action] or on 
the black triangle to the right. It will ask you which Function key you wish to assign to 
your macro, I selected F2 for instance. I named my action ‘Fill’. 
 
‐ Press [Record], this will start the recording of any further action in Photoshop. 
 
‐ Now as a selection is active do [Edit] →[Fill]. 
 
‐ On the actions window, press the black square to stop recording.  
 
‐ The macro should now work, and F2 can be used to fill.  
 
This is just an example and any other key or action can be made to accelerate the 
process. 
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E. Creating the “glass” layer 
 
This layer should represent all the background stuff that will not be analyzed in FOAMS. 
In our case these are the glass walls corresponding to the areas that are neither 
bubbles, nor crystals.  
 

- First create a new layer name “glass”. Deactivate it. 
 

- Make duplicates of each of the other layers that contain the different objects 
(crystals, bubbles…).  
 

- Activate only the object duplicates and deactivate everything else.  
 

- In each copy, use the magic wand or the select color range tool to select all 
objects. Fill them all in black. Eerything except the background should now be 
black. 
 

- Now merge the visible duplicates together with [Layer]→[Merge Visible].  
 

- Then either do a magic wand on a black area or select color range, and go to 
[Select]→[Invert].  
 

- Activate the new “glass” layer you created and do a fill with the color you chose 
for your base object (ex: light gray). And Voila! You can delete the duplicate layer 
created with merged objects. 

 
 
 
F. Putting it all together 
 
Layers should be organized before making the final merge. To change their order (top to 
bottom), just displace them into the layer window. In our case we have: 
 

- Crystals (white) 
- Leucites (dark grey) 
- Glass (light grey) 
- Bubbles (black) 

 
At this stage, especially in the case of pumice, some glass wall reconstructions need to 
be performed.  
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G.  Reconstruction 
 
 
Use the pencil tool for glass wall reconstruction since it is devoid of any anti‐aliasing and 
smoothing. This is a long and tricky part. Unfortunately no automation can come to our 
rescue here.  
 
Because you are going to want to often make the layer you are modifying 
visible/invisible to compare with the background layer (which you should leave visible at 
all times) a good thing to have at that point is a macro to be able to toggle views with 
your keyboard. To generate such a macro: 
 

- make the current active layer invisible but still activated 
- create another action just like you did for your F2 ‘fill’ function 
- name it ‘visible’ for example and choose the F3 function key 
- now press OK, it will start recording your actions 
- go to the [Layer] menu and select [show layers] your layer should be visible now 
- on the little actions windows press the little blackish square to stop recording  
- now do the same except that you start with your layer being visible and choose 

the F4 function key 
- when it records choose [Layer] and [Hide layers] 
- stop recording and test your F3 and F4 toggling visible/invisible 

 
Another way to have the background somewhat visible is to make the glass layer 
transparent (60% opacity or less). 
 
 
 
 
H. The final image 
 
When you feel all reconstructions/corrections are done, save another version of your 
work as a merged image of only the objects layers generated and the glass layer. To do 
do [Layers] →[Merge visible]. Now save your work again but this time as a .tif 
document with the extension ‘merged’.  
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Some helpful shortcut keys and clicks: 
 
Deselect all: Ctrl+D 
Undo: Ctrl+Z 
Undo previous: Ctrl+Alt+Z 
Make new layer: Ctrl+Shift+N 
Levels: Ctrl+L 
Choose the Pencil tool: N 
Choose the Lasso tool: L 
Zoom in: Alt+Mousewheel up 
Zoom out: Alt+Mousewheel down 
Pan Horizontally: Ctrl+ Mousewheel up (left) or down (right) 
Pan Vertically: Mousewheel up or down 
 
 
 
 
 
 
 
 
 

REMEMBER TO SAVE YOUR WORK VERY OFTEN! 
 
 
 
 


