Quick Start Guide

MCC DAQ
Software

InstaCal™
Installation utility

TracerDAQ®
Ready-to-run DAQ application

Universal Library™
Windows programming libraries and components

ULx for NI LabVIEW™
Drivers and examples

Hardware/User Manuals
and documents

System Requirements
Windows™/Vista/XP (SP2)

mccdaq.com

All rights reserved. Made in USA

10 Commerce Way
Norton, MA 02766
Tel: (508) 946-5100
Fax: (508) 946-9500
Table of Contents

About Measurement Computing data acquisition software ........... 4
  ■ System requirements ................................................................. 4
  ■ For more information................................................................. 6

Installing the Measurement Computing DAQ software ............... 7

Installing the hardware and detecting it with Windows................... 9

Adding new hardware to InstaCal............................................... 10
  ■ InstaCal overview..................................................................... 10
  ■ Installation................................................................................ 10
  ■ Configuration........................................................................... 10
  ■ Calibration................................................................................ 11
  ■ Test .......................................................................................... 11

Running InstaCal and adding DEMO-BOARD hardware ............... 12
  ■ Running InstaCal and adding the DEMO-BOARD ....................... 12

Configuring and testing the DEMO-BOARD with InstaCal .......... 14
  ■ Configuring channel 0 on the DEMO-BOARD ......................... 14
  ■ Testing channel 0 on the DEMO-BOARD .................................... 14

Plotting and generating data with TracerDAQ........................... 16
  ■ Acquiring and logging data with the Strip Chart .................... 16
  ■ Acquiring data with the Oscilloscope ...................................... 19
  ■ Generating waveforms with the Function Generator ............... 22
  ■ Generating waveforms with the Rate Generator .................... 25

Getting started with the Universal Library.............................. 28

Getting started with ULx for NI LabVIEW............................... 29

Opening your hardware user's guides...................................... 31

Problems installing or running your DAQ software? ................. 31
About Measurement Computing data acquisition software

This Quick Start Guide contains the latest information on installing the Measurement Computing Data Acquisition Software you received with your Measurement Computing hardware. Please read this booklet completely before you install any software or hardware.

Measurement Computing's data acquisition software includes the following software packages:

- **InstaCal & Universal Library™** — Installation, calibration, and test utility and programming library for Measurement Computing data acquisition hardware.
- **TracerDAQ®** — Virtual instrument application suite with Strip Chart, Oscilloscope, Function Generator, and Rate Generator applications.
- **ULx for NI LabVIEW™** — Library of virtual instruments (VIs) and example programs used with National Instruments LabVIEW to develop instrumentation, acquisition, and control applications for Measurement Computing data acquisition hardware.
- **Hardware User's Guides** — Hardware user's guides for Measurement Computing data acquisition hardware.

You select the packages that you want to install from the software installation dialog.

### System requirements

You can install the Measurement Computing Data Acquisition Software on a computer running one of these operating systems:

- Windows 7
- Windows VISTA
- Windows XP SP 2

64-bit operating systems support Measurement Computing USB, WLS, WEB, and PCI hardware only. View the readme files in the \ICalUL directory of the Measurement Computing Data Acquisition Software CD for more information.

These operating systems are the only requirements for running InstaCal. The hardware and software requirements for the other packages are listed next.
Universal Library

Application development software that supports one or more of these development languages:

- **Microsoft® Windows® languages**: Visual Basic and Visual C/C++

TracerDAQ

TracerDAQ requires the following software to be installed:

- Microsoft .NET® Framework 2.0
- DirectX 9.0c
- Measurement Computing InstaCal

The Microsoft .NET® Framework 2.0 and DirectX 9.0c automatically install with TracerDAQ if these applications are not already installed.

**Hardware requirements**

- Video card with 16 MB of memory and support for Direct3D Acceleration
- Minimum screen resolution of 1024 x 768
- Computer with Pentium® 4 processor and 256 MB of RAM
- A Microsoft-compatible mouse
- Supported MCC data acquisition hardware:


ULx for NI LabVIEW

- InstaCal & Universal Library
- LabVIEW 8.2.1 or later (32-bit only)
- Microsoft .NET® Framework 2.0

**Note:** Universal Library for NI LabVIEW legacy drivers compatible with LabVIEW Version 6.0–8.2 can also be installed from the software CD. New users, however, should install the ULx for NI LabVIEW.
Hardware User's Guides

Software requirements

- Adobe® Reader®

Adobe Reader is automatically selected if you install the Measurement Computing hardware user's guides and do not have this program currently installed.

For more information…

If you have questions that you cannot answer by reading this booklet, refer to these resources:

- Tech support form: www.mccdaq.com/support/support_form.aspx
- Email: techsupport@mccdaq.com
- Phone: 508-946-5100 and follow the instructions for reaching Tech Support.
- Fax: 508-946-9500 to the attention of Tech Support
Installing the Measurement Computing DAQ software

The DAQ Software installation program consists of a series of easy-to-follow dialogs that lead you through the installation procedure. To install the Measurement Computing DAQ software, do the following.

1. Insert the *Measurement Computing Data Acquisition Software* CD in your CD drive and wait for the installation program to start.

   If the installation program does not start automatically, use Windows Explorer to browse to the root of the CD, and double-click on `Install.exe`.

   The **MCC DAQ** dialog opens.

   ![MCC DAQ dialog](image)

   All software packages are selected for installation (☑) by default if the requirements for the package are met.

   - When you click on a package, a brief description of it appears in the **Description** frame, along with the requirements to install that package.
   - After you click on a package, you can click on the **View ReadMe** button to view the readme file for that package.
2. If you do not want to install a software package, click on the check box next to it to uncheck it.

The Required dependencies area lists the software packages needed to run the Measurement Computing DAQ software you selected to install. This area may be blank, or may list one or more of the following packages:

Adobe Reader - Adobe Reader is required to read the hardware user's guides. If you do not have Adobe Reader installed, it is listed in the Required dependencies area and the checkbox is checked. If you have an earlier version already installed, installing the latest version is optional. Deselect the Adobe Reader check box to keep your currently installed version.

Microsoft .NET framework - The .NET Framework 2.0 is required to install TracerDAQ, ULx for NI LabVIEW, and the hardware user's guides. If the framework is not detected on your PC, this package is listed and the checkbox is checked. In this case, it is recommended that you leave the Microsoft .NET framework check box checked. If you uncheck the Microsoft .NET framework check box, the TracerDAQ, ULx for NI LabVIEW, and Hardware Manuals check boxes become disabled, the Adobe Reader check box becomes unchecked, and these packages are not installed.

3. Click on the Install button and follow the instructions on the installation dialogs.

If Microsoft .NET framework was checked in the Required dependencies area, the install program installs version 2.0 of the .NET framework before launching the InstaCal & Universal Library installation program. The installation program automatically installs each selected software product in succession. After all selected Measurement Computing DAQ components are installed, a dialog opens which lets you install Adobe Acrobat Reader.

You are prompted to restart your computer after installing all of the selected products.
Installing the hardware and detecting it with Windows

After you install the *Measurement Computing Data Acquisition Software*, install your hardware and let it be detected by Windows.

- For PCI devices, turn the PC off, install the device into a PCI slot, and turn the PC back on.

  When you power up the PC, a "Found new hardware" message appears as the device is detected by Windows. A New Hardware Wizard automatically runs and installs the drivers required to operate the device.

- For plug-and-play USB devices, connect a USB cable between the device and the PC.

  A "Found new hardware" message appears as the device is detected by Windows. A New Hardware Wizard automatically runs and installs the drivers required to operate the device.

---

**Additional New Hardware Wizard may appear**

When installing some measurement computing devices, such as the USB-2416 Series and USB-2404 Series, an additional New Hardware Wizard may appear when you install the hardware. This wizard is required to install additional drivers specific to this hardware. DO NOT CANCEL THIS WIZARD or installation of the hardware will not be completed properly.
Adding new hardware to InstaCal

After the device is detected with Windows, run InstaCal from the Windows Start Menu or from the installation directory (inscal32.exe) so that it can detect the new hardware and add it to its configuration file.

Measurement Computing hardware cannot be used with Universal Library programs until they are first detected by InstaCal and added to the configuration file.

InstaCal overview

InstaCal is an installation, configuration, calibration, and test program for use with Measurement Computing hardware. With InstaCal, you can change device configuration settings, calibrate analog inputs and outputs, and test the device's analog channels and digital ports.

Installation

- **PCI and USB** hardware: these devices are automatically detected by InstaCal and added to the board list after they are plugged in/connected to the PC.
  
  InstaCal will also detect removal of a PCI or USB device that is no longer connected to the PC, and will prompt you to remove the device from the board list.

- **ISA, PC104, PPIO, WEB, and E-PDISO16** hardware: these devices must be manually added to InstaCal after they are plugged in/connected to the PC.

  From the InstaCal drop-down menu, select **Install > Add Board** to display a group of tabs. Each tab lists the devices you can install. Once selected, the device is added to InstaCal and the board list, and remains there until removed.

  The InstaCal main form lists each device that it automatically detects or that is manually added to the board list.

Configuration

To change the configuration settings of a device, double-click on the device name to open a **Board Configuration** dialog. The settings which appear are specific to the device selected.

A common configuration task for A/D boards is to set the analog input channel mode to either single-ended or differential.

InstaCal stores hardware configuration settings in a configuration file which is read by the Universal Library when you run an application. To change device settings, stop the UL application and run InstaCal.
Multithreading is not supported
Only one application program that calls the Measurement Computing driver can be running at a time. If the device is used by a Universal Library program, changes to device configuration settings can only be made when the program is not running.

Calibration
InstaCal can calibrate the analog input or output channels for DAQ devices that support field calibration. Select the device from the InstaCal main form, and choose A/D or D/A from the Calibrate menu. A Board Calibration dialog appears. Follow the instructions on the dialog to calibrate the desired channels.

Test
InstaCal provides analog and digital tests to determine if the channels analog inputs and digital bits are working properly. To test the device, select either Test > Analog or Test > Digital. A Board test dialog appears with options specific to the selected device.

- Analog input tests may include a Loopback test and a Scan test.
  - Perform a Loopback test to verify the analog connections, and that the basic analog measurement operation is working properly. With this test, one channel at a time is tested in a slow (non-clocked) sampling mode. You can loop back one of the onboard signals or use an external signal.
  - Perform a Scan test to sample multiple channels simultaneously at a specified clock rate. The Scan test is a good test of the DMA and IRQ resources assigned to the card. Acquired data can be displayed graphically or numerically.

- Digital tests may include an External DI test and an External DO test which verify the input or output operation of each digital bit.

Depending on the hardware, additional tests may also be available, such as Internal CTR and External CTR.
This section contains hands-on examples that show you how to use InstaCal to configure and test the DEMO-BOARD, which is a virtual ISA data acquisition board.

Running InstaCal and adding the DEMO-BOARD

This section explains how to run InstaCal and add the DEMO-BOARD to the InstaCal configuration.

1. To run InstaCal, click on Start►Programs►Measurement Computing►InstaCal.

   The InstaCal main form opens:

2. Click the right mouse button on the PC Board List, and select Add Board... from the popup menu.

   The Board Selection List dialog opens.

3. Click on the ISA tab.

4. Scroll down to select DEMO-BOARD, and then click on the Add button.
Running InstaCal and adding DEMO-BOARD hardware

The DEMO-BOARD is added to the InstaCal main form.

Now that you have added the DEMO-BOARD you can use this form to configure and test the DEMO-BOARD.
Configuring and testing the DEMO-BOARD with InstaCal

You can configure and test the DEMO-BOARD with InstaCal.

For other Measurement Computing devices, the available configuration settings and testing options vary depending on the type of device and the features it offers.

Configuring channel 0 on the DEMO-BOARD

In the following example, use InstaCal to change the configuration of channel 0 on the DEMO-BOARD.

1. On the PC Board List, double-click the DEMO-BOARD item.
   
   The Board Configuration dialog for the DEMO-BOARD opens.

2. Change the input type for channel 0 from Sine Wave to Damped Sine Wave, and click on the OK button to close the dialog.

   ![Board Configuration Dialog]

   Now you can run a test using InstaCal to make sure the DEMO-BOARD's channel 0 generates a damped sine wave.

Testing channel 0 on the DEMO-BOARD

InstaCal includes options to test the analog and/or digital features of your Measurement Computing hardware.

For the DEMO-BOARD, run the analog loop back test to verify that the channel is generating the proper waveform.

1. Select the DEMO-BOARD on the PC Board List.

2. From the Test menu, select Analog.

   ![Test Menu]

   The Board Test: DEMO-BOARD at 0h dialog opens.
3. Make sure *Ch 0* is selected in the **Input Ch** drop-down list, and a damped sine wave shows on the display. Then click on the **OK** button to close the dialog.

4. From the **File** menu, select **Exit** to close InstaCal.

Next, you will learn how to run TracerDAQ's Strip Chart application to acquire, plot, and log data from four channels on the DEMO-BOARD.
Plotting and generating data with TracerDAQ

TracerDAQ includes the following applications:

- Strip Chart with data logging functionality
- Oscilloscope
- Function Generator
- Rate Generator

Hands-on examples for each TracerDAQ application are included in the following sections.

After you configure and test your hardware with InstaCal, you can run TracerDAQ and use the DEMO-BOARD with the Strip Chart and Oscilloscope.

To run TracerDAQ, click on Start ► Programs ► Measurement Computing ► TracerDAQ ► TracerDAQ. The TracerDAQ dialog opens. You can run any of the four TracerDAQ applications from this dialog.

**Acquiring and logging data with the Strip Chart**

Use the Strip Chart to acquire and log data from up to eight analog input, temperature input, digital input, or event counter channels.

To run the Strip Chart, highlight it on the application list, and then click the **Run** button.

The **Strip Chart** window opens.
Plotting and generating data with TracerDAQ

Configuring the Strip Chart

Once the Strip Chart window is open, you need to select the hardware, channel(s), and data range used as the data source.

1. From the File menu, select New…. The DAQ Hardware Settings dialog opens.

2. From the first row of the DAQ Device column, select the DEMO-BOARD from the drop-down list.

The drop-down list shows the device ID and device name for all boards that are configured by InstaCal. When you select a device, the first channel and range supported by the device appear in the DAQ Channel and DAQ Range/Mode columns.

3. Right-mouse click on the first column, and select AutoFill All from the popup menu. This automatically configures the DAQ Device, DAQ Channel and DAQ Range/Mode for the remaining channels on the dialog.

The dialog automatically becomes configured to acquire data from four channels on the DEMO-BOARD.

4. Click OK to save the settings and close the dialog.

5. From the Edit menu, select Scan Rate/Trigger Settings…. The Scan Rate/Trigger Settings dialog opens.

6. Change the Acquire data for settings so that the scan runs for 5 seconds, and then click OK to save the settings and close the dialog.
7. To view plots that don't overlap, click on the scan mode hotspot (A) on the upper right side of the strip chart window until it turns to (non-overlap mode).

8. Click the Run button (B) on the Strip Chart to acquire data from the DEMO-BOARD.

The Strip Chart acquires and displays data from the first four channels (0 -3) of the DEMO-BOARD.

That's all there is to it! The Strip Chart provides many options for working with Strip Chart data and customizing the Strip Chart display. To learn more about the Strip Chart, select Help Topics from TracerDAQ's Help menu.
Additional features available with TracerDAQ Pro
If you upgrade to TracerDAQ Pro, you can also:

▪ Acquire and plot data from up to 32 channels
▪ Acquire and plot up to 1 million samples per channel
▪ Set alarm conditions
▪ Set software, hardware, and time-of-day triggering
▪ Apply linear scaling

For more information on TracerDAQ Pro, refer to www.mccdaq.com/daq-software/tracerdaq-pro.aspx.

Want to remove the DEMO-BOARD before you start using your MCC device?
The DEMO-BOARD is a teaching tool to help you get up and running with your MCC-DAQ software. Once you feel comfortable enough to start using the device you purchased, you can remove the DEMO-BOARD from the InstaCal main form by clicking on it with the right-mouse button and selecting **Remove Board** from the popup menu.

Acquiring data with the Oscilloscope
Use the Oscilloscope to acquire and plot data from up to two analog input channels.

To run the Oscilloscope, highlight it on the application list and click the **Run** button.
Configuring the Oscilloscope

Once the Oscilloscope window is open, to select the hardware, channel(s), and data range used as the data source.

1. From the File menu, select New.... The DAQ Hardware Settings dialog opens.

2. From the first row of the DAQ Device column, select the DEMO-BOARD from the list-box.

   The drop-down list shows the device ID and device name for all boards that are configured by InstaCal. When you select a device, the first channel and the default range supported by the device appear in the DAQ Channel and DAQ Range/Mode columns.

3. Right-mouse click on the first column and select AutoFill All from the popup menu. This automatically configures the DAQ Device, DAQ Channel and DAQ Range/Mode for the remaining channel on the dialog.

4. Click the DAQ Range/Mode column's down arrow and select +/-5V. The range automatically updates for both channels.

5. On the Oscilloscope window, click the Start button ( ).

   The Oscilloscope acquires and displays data from the first two channels (0 - 2) of the DEMO-BOARD.
6. To stop the scan, click on the **Stop** button (\(\text{Stop}\)).

That's all there is to it! The Oscilloscope provides many options for working with Oscilloscope data and customizing the Oscilloscope display. To learn more, select **Help Topics** from the **Help** menu.

---

### Additional features available with TracerDAQ Pro

If you upgrade to TracerDAQ Pro, you can also:

- Acquire and plot data from up to four analog input channels
- Set up a reference and math channel


---

### Want to remove the DEMO-BOARD before you start using your MCC device?

The DEMO-BOARD is a teaching tool to help you get up and running with your MCC-DAQ software. Once you feel comfortable enough to start using the device you purchased, you can remove the DEMO-BOARD from the InstaCal main form by clicking on it with the right-mouse button and selecting **Remove Board** from the popup menu.
Generating waveforms with the Function Generator

Use the Function Generator to output sine wave data to one analog output channel.

To use TracerDAQ's Function Generator application, you first need to install a Measurement Computing device with analog output channels and add it to InstaCal.

In order for the Function Generator to detect this device, you must add it to InstaCal when TracerDAQ is not running.

1. If you are running any TracerDAQ application, close the application by selecting Exit from the File menu.
2. Close TracerDAQ by clicking on the Exit button on the main TracerDAQ dialog.

Adding an analog output device to InstaCal

1. Follow the steps in the analog output device's user guide to install the device in your computer.
2. Run InstaCal by selecting Start►Programs►Measurement Computing►InstaCal.

The Plug and Play Hardware Detection dialog opens with the analog output device listed.

3. Select the analog output device you want to add to the InstaCal configuration file, and then click on the OK button.

This example shows the USB-1208FS detected.

The Plug and Play Hardware Detection dialog closes, and the InstaCal main form becomes active.
4. Use InstaCal to perform any configurations and tests on the device. When you are done, close InstaCal by selecting Exit from the File menu.

Configuring and running the Function Generator

Now that your analog output device has been added to InstaCal, you can run TracerDAQ and access the device from the Function Generator.

To generate a waveform with the Function Generator:

1. Run TracerDAQ by selecting Start►Programs►Measurement Computing►TracerDAQ►TracerDAQ.

   The TracerDAQ dialog opens.

2. To run the Function Generator, highlight it on the application list, and then click the Run button.

3. The Function Generator window opens.

4. Select New... from the File menu. The DAQ Hardware Settings dialog opens.

5. From the first row of the DAQ Device column, select the analog output device from the list-box. The USB-1208FS is used for this example.
The drop-down list shows the device ID and device name for all analog output devices that are configured by InstaCal. When you select a device, the first analog output channel and the default range supported by the device appear in the **DAQ Channel** and **DAQ Range/Mode** columns.

6. Click on the **OK** button to save the settings and close the dialog.

7. Click the **Run** button (▶) on the Function Generator to start an output scan that sends waveform data to the configured channel. The USB-1208FS requires a positive DC level setting equal to the amplitude setting to avoid clipping the waveform at 0 volts.

The Function Generator sends a sine wave pattern with the amplitude and DC level option settings shown in the example below.

8. To stop the scan, click on the **Stop** button (■).

That’s all there is to it! The Function Generator provides many options that let you change the properties of the waveform, DAQ hardware, and the Function Generator display. To learn more about the Function Generator, select **Help Topics** from TracerDAQ’s **Help** menu.

### Additional features available with TracerDAQ Pro

If you upgrade to TracerDAQ Pro, you can also:

- Generate square, triangle, flat, pulse, ramp, random, and arbitrary waveforms from a text file (.csv or .txt)
- Set duty cycle, phase, gate ratio, and rate multiplier options
- Enable a linear or exponential sweep of the waveform

Generating waveforms with the Rate Generator

Use the Rate Generator to output data to one counter output channel.

To use TracerDAQ's Rate Generator application, you first need to install a Measurement Computing counter output device and configure it in InstaCal.

In order for the Rate Generator to detect this device, you must add it to InstaCal when TracerDAQ is not running.

1. If you are running any TracerDAQ application, close the application by selecting Exit from the File menu.
2. Close TracerDAQ by clicking on the Exit button on the main TracerDAQ dialog.

Adding a counter output device to InstaCal

1. Follow the steps in the counter output device's user guide to install the device in your computer.
2. Run InstaCal by selecting Start►Programs►Measurement Computing►InstaCal.

The Plug and Play Hardware Detection dialog opens with the counter output device listed.

3. Select the counter output device you want to add to the InstaCal configuration file, and then click on the OK button. The USB-2517 is used for this example.

The Plug and Play Hardware Detection dialog closes, and the InstaCal main form becomes active.

4. Use InstaCal to perform any configurations and tests on the device. When done, close InstaCal by selecting Exit from the File menu.
Configuring and running the Rate Generator

Now that your counter output device has been added to InstaCal, you can run TracerDAQ and access the device from the Rate Generator.

To generate a square waveform with the Rate Generator:

1. Run TracerDAQ by selecting **Start**►**Programs**►**Measurement Computing**►**TracerDAQ**►**TracerDAQ**.

   The TracerDAQ dialog opens.

2. To run the Rate Generator, highlight it on the application list, and then click the **Run** button.

3. The **Rate Generator** window opens.

4. Select **New...** from the **File** menu. The **DAQ Hardware Settings** dialog opens.

5. From the first row of the **DAQ Device** column, select the counter output device from the list-box.

   The drop-down list shows the device ID and device name for all counter output devices that are configured by InstaCal. When you select a device, the device's first counter output channel appears in the **DAQ Channel** column. The **DAQ Range/Mode** column is disabled.

6. Click on the **OK** button to save the settings and close the dialog.

7. Click the **Run** button ( ) on the Rate Generator to start an output scan that sends waveform data based on the frequency option settings to the default channel.
By default, the Rate Generator sends a square wave pattern with the option settings shown in the example below.

8. To stop the scan, click on the **Stop** button (■).

That's all there is to it! The Rate Generator provides many options that let you change the properties of the waveform, DAQ hardware, and the Rate Generator display. To learn more about the Rate Generator, select **Help Topics** from TracerDAQ's **Help** menu.

**Additional feature available with TracerDAQ Pro**

If you upgrade to TracerDAQ Pro, you can generate waves for up to 20 counter output channels.

Getting started with the Universal Library

The Universal Library (UL) provides a programming library you can use to develop applications that control Measurement Computing hardware.

The Universal Library supports programming in Visual Basic, VB .NET, Visual C/C++, C# .NET, and other languages.

The Universal Library is automatically installed with InstaCal. The default installation directory is `\Program Files\Measurement Computing\DAQ`.

**Universal Library example programs**

You can install example programs for supported languages when you install the Universal Library software.

- On Windows XP, the example programs are installed by default to `\Program Files\Measurement Computing\DAQ`.
- On Windows 7 and Windows Vista, the example programs are installed by default to `\Users\Public\Documents\Measurement Computing\DAQ`.

**Note:** The VB .NET and C# example program projects were generated with Visual Studio 2005 and will not open in Visual Studio 2003. To run the example programs in Visual Studio 2003, add the .vb or .cs source files to an empty project and reference the mccdaq.dll assembly.

When you install the example programs, an *Examples* shortcut is added to the directory where you installed the UL software. When selected, the directory containing the example programs opens in Windows Explorer.

**Online help**

To learn about the Universal Library functions and how to use them with Measurement Computing hardware, refer to the *Universal Library Help* file. To open this help file select **Start ► Programs ► Measurement Computing ► Universal Library ► UL Help**.

For information on your specific Measurement Computing device, use the *Search* tab in the help file. The help topic for your device lists the subset of Universal Library functions that your device supports.
Getting started with ULx for NI LabVIEW

The ULx for NI LabVIEW is a library of virtual instruments (VIs) used with Measurement Computing hardware to develop instrumentation, acquisition, and control applications in National Instruments LabVIEW 8.2.1 and later. The ULx for NI LabVIEW library syntax is consistent with LabVIEW DAQmx VIs.

The ULx for NI LabVIEW library is task-based. Every measurement or output operation performed in a DAQ operation, such as analog input, digital output, and so on, is a separate task. Each task is associated with one hardware device and one or more channels of the same type.

ULx for NI LabVIEW example programs

The ULx for NI LabVIEW provides example programs that demonstrate how to perform data acquisition tasks using the ULx VIs in LabVIEW. You should run the example programs before creating your own VIs or programs. You can modify the example programs to suit your needs.

You can open a ULx for NI LabVIEW example program from its default installation directory (\Program Files\National Instruments\LabVIEW <version>\examples\ULx) or with the NI Example Finder utility in LabVIEW.

Note: You must configure your MCC hardware with InstaCal before it can be recognized in LabVIEW.

Adding a ULx VI to NI LabVIEW

To add a ULx VI to LabVIEW, do the following:

1. Start LabVIEW and open a blank VI or empty project. View the Block Diagram if it is not already open.
2. From the Functions palette, click User Libraries and then click the MC ULx icon to display the ULx VIs on the ULx for NI LabVIEW palette.
3. Click to select a ULx VI, and then click on the Block Diagram where you want to place the VI. Repeat to add additional ULx VIs to the Block Diagram.

4. Wire the ULx VIs together to create an application.

**Online help**

For detailed information on each ULx VI, refer to the *ULx for NI LabVIEW Help* file. To run this help file select **Start►Programs►Measurement Computing►ULx for NI LabVIEW►Help.**
Opening your hardware user's guides

If you installed the Measurement Computing hardware user's guides during the DAQ software installation, you can open your hardware manual right from within InstaCal.

You need Adobe Reader to open the user's guides. You can install this software from the AcrobatReader folder on the CD.

1. Select **User's Guides** from the InstaCal **Help** menu.
2. From the **Open** dialog, double-click on the folder for the type of board whose manual you want to open (USB, PCI, and so on).
3. Double-click on the PDF hardware manual to open it.

---

**Accessing hardware user's guides from the Measurement Computing DAQ Software CD**

If you did not install the Measurement Computing hardware user's guides during the DAQ software installation, you can open or copy these documents from the *ICalUL/Documents/UsersGuides* folder on the Measurement Computing DAQ Software CD.

---

**Problems installing or running your DAQ software?**

For software and hardware questions:

- Tech support form: [www.mccdaq.com/support/support_form.aspx](http://www.mccdaq.com/support/support_form.aspx)
- Email: techsupport@mccdaq.com
- Phone: 508-946-5100 and follow the instructions for reaching Tech Support.
- Fax: 508-946-9500 to the attention of Tech Support

Customers outside of the U.S. should contact their local Measurement Computing distributor for support.

Refer to [www.mccdaq.com/contact2.aspx](http://www.mccdaq.com/contact2.aspx) to locate a distributor.
Trademark and Copyright Information
TracerDAQ, Universal Library, Measurement Computing Corporation, and the Measurement Computing logo are either trademarks or registered trademarks of Measurement Computing Corporation.

Windows, Microsoft, and Visual Studio are either trademarks or registered trademarks of Microsoft Corporation.
LabVIEW is a trademark of National Instruments.
All other trademarks are the property of their respective owners.

Information furnished by Measurement Computing Corporation is believed to be accurate and reliable. However, no responsibility is assumed by Measurement Computing Corporation neither for its use; nor for any infringements of patents or other rights of third parties, which may result from its use. No license is granted by implication or otherwise under any patent or copyrights of Measurement Computing Corporation.

All rights reserved. No part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form by any means, electronic, mechanical, by photocopying, recording, or otherwise without the prior written permission of Measurement Computing Corporation.

Notice
Measurement Computing Corporation does not authorize any Measurement Computing Corporation product for use in life support systems and/or devices without prior written consent from Measurement Computing Corporation. Life support devices/systems are devices or systems which, a) are intended for surgical implantation into the body, or b) support or sustain life and whose failure to perform can be reasonably expected to result in injury. Measurement Computing Corporation products are not designed with the components required, and are not subject to the testing required to ensure a level of reliability suitable for the treatment and diagnosis of people.